Make a WordPress 2.1 Theme Work on WP 2.0.x

Are you still running WordPress 2.0.x or an older version? You may find that newly released themes do not work with your install. This has been something of a headache for me, especially as I have released several WP themes over the last week or so and the popular theme viewer at themes.wordpress.net still appears to be running on an old version of WordPress. The themes I was uploading there were giving an error message as early as line 2 of the header! Anyway, heres some handy tips for anyone with a similar situation.

You might not need to perform all these changes; not all themes are equal :)

In sidebar.php

  • replace wp_list_bookmarks() with get_links_list()
  • replace <?php wp_list_categories(‘show_count=1&title_li=0′); ?> with <?php wp_list_cats(‘sort_column=name&optioncount=1&hierarchical=0′); ?>

In header.php

  • delete <?php language_attributes(); ?>

In searchform.php

  • delete <?php the_search_query(); ?>

In function.php

  • replace wp_list_bookmarks() with get_links_list()

One thought on “Make a WordPress 2.1 Theme Work on WP 2.0.x

  1. Pingback: pilkster.com » Blog Archive » Make a Wordpress 2.1 Theme Work on WP 2.0.x

Leave a Reply